Starting with mongodb

3:23 AM 0 Comments

 Create a new rails application for mongo, so let's skip active record as it's not required.

rails new appname --skip-active-record
In case if want to skip bundle, append this --skip-bundle whereas if you
want to use mysql as default append this -d mysql

Use the following rails versions which are release after the security fix,
      3.2.11
      3.1.10
      3.0.19
      2.3.15


rails g mongoid:config

Checkout for mongoid.yml for db configuration.

Check for config/application.rb. it would have the below lines.
 # Pick the frameworks you want:
# require "active_record/railtie"
 require "action_controller/railtie"
 require "action_mailer/railtie"
 require "active_resource/railtie"
 require "sprockets/railtie"
 require "rails/test_unit/railtie"

Some basic things which can be followed for good practices. Setup RVM Then create a gemset,
rvm gemset create analytics 
o/p: gemset created analytics => /home/bijendra/.rvm/gems/ruby-1.9.3-p286@analytics
Creating gemsets specific to project is considered better and you can have a better control over the gem versions.

Bijendra Singh

Some say he’s half man half fish, others say he’s more of a seventy/thirty split. Either way he’s a fishy bastard.

0 comments: